High-Tech

Jailbreak iOS 7 : la compatibilité limitée de Cydia

Jailbreak iOS 7

Si tout le monde parle de jailbreaker son iPhone pour par exemple pour installer Cydia, personne ne parle de la compatibilité de Cydia avec les différentes versions d’iOS. C’est pour répondre à cette question qu’Evad3rs vient de publier une liste de compatibilité.
Que vous le croyez ou pas, le travail des hackers en charge de développer un jailbreak pour les différentes moutures du système d’exploitation mobile d’Apple ne se résume pas uniquement découvrir des failles de l’OS et de les exploiter. Leur tâche va bien plus loin.

L’exemple classique est Cydia, une application intégrée au jailbreak pour pouvoir notamment télécharger et installer d’autres applications que celle proposées par Apple. Mais voilà, cette application doit aussi suivre le rythme des versions d’iOS.

Malheureusement, tout n’est pas si simple, c’est ce que vient de dévoiler la team Evad3rs. Selon une liste des tweaks compatibles avec les différentes versions d’iOS, toutes les fonctionnalités sont disponibles jusqu’à iOS 6.1.3. Après, tout n’est pas compatible…

Même si Evad3rs vient de publier un cliché de Cydia fonctionnant sur un iPhone 5S sous iOS 7, cela ne signifie donc pas que tout et 100% opérationnel. Mobile Terminal, Mobile Substrate et Preference Loader fonctionnent parfaitement, iFile, Substrate Safe Mode et Volume Customize marchent partiellement alors qu’Activator, Emphasize, f.lux, Zephyr ou encore Zeppelin ne sont carrément pas compatibles. Sans ces tweaks de Cydia, il est donc impossible de pouvoir utiliser les applications non signées d’Apple.

De fait, des progrès ont été faits sur le jailbreak lui-même, des progrès ont été effectués sur Cydia avec une nouvelle interface dans le design iOS 7, mais le travail à faire est encore énorme. La patience est donc d’autant plus de rigueur en sachant tout ce qui reste à accomplir.

Populaires

To Top